野火电子论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 4702|回复: 7

串口软件为何一执行打开串口就收到乱码

[复制链接]
发表于 2015-11-1 18:14:40 | 显示全部楼层 |阅读模式
本帖最后由 Natto 于 2015-11-1 19:09 编辑

请教:为何串口调试助手一点打开串口,就收到一大串乱码,是代码有误么,程序和问题图如下
#include"CustomHeader.h"
int main(void)
{
        unsigned char ak[12]="This is one";
        u16 i;

        GPIOSet();
        //SysTick_Init();
        USARTSet();
        NVICSet();
        
        while(1)
        {

                for(i=0;ak[i]!='\0';i++)
                {
                        USART_SendData(USART1,ak[i]);
                        while(USART_GetFlagStatus(USART1,USART_FLAG_TC)==RESET);
                }
        }
}
usart.jpg
回复

使用道具 举报

发表于 2015-11-2 08:49:36 | 显示全部楼层
串口标志位用错了,改成这样

                USART_SendData(DEBUG_USART, (uint8_t) ch);
               
                /* 等待发送完毕 */
                while (USART_GetFlagStatus(DEBUG_USART, USART_FLAG_TXE) == RESET);               
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-11-2 21:02:40 | 显示全部楼层
flyleaf 发表于 2015-11-2 08:49
串口标志位用错了,改成这样

                USART_SendData(DEBUG_USART, (uint8_t) ch);

USART_FLAG_TXE不是发送数据寄存器为空的标志位么,难道不用管数据发送完成标志位,只需要发送寄存器为空就可以了?
回复 支持 反对

使用道具 举报

发表于 2017-10-16 08:36:33 | 显示全部楼层
回复

使用道具 举报

发表于 2017-10-17 13:00:00 | 显示全部楼层
请勾选16进制显示,你的图片是hex显示,把那个勾选上
回复 支持 反对

使用道具 举报

发表于 2017-10-20 16:00:09 | 显示全部楼层
:)
回复

使用道具 举报

发表于 2018-1-26 13:38:33 | 显示全部楼层
:):):):):):)
回复 支持 反对

使用道具 举报

发表于 2018-1-31 11:21:30 | 显示全部楼层
波特率??设置错了
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

联系站长|手机版|站点地图|野火电子官网|野火淘宝店铺|野火电子论坛 ( 粤ICP备14069197号-2 ) 大学生ARM嵌入式2群

GMT+8, 2020-8-5 08:42 , Processed in 0.154134 second(s), 28 queries , Gzip On.

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表